Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 20 · одна куча, камни добавляются

Задание 20 ЕГЭ: одна куча, камни добавляются

Одна куча, камни добавляются: Петя выигрывает вторым ходом. Тема номера — выигрышная стратегия вторым ходом. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может:

Например, имея кучу из 11 камней, за один ход можно получить кучу из 13 или 33 камней.

Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней. Игра завершается в тот момент, когда количество камней в куче становится не менее 101. Победителем считается игрок, сделавший последний ход, то есть первым получивший такую позицию, при которой в куче будет 101 или больше камней. В начальный момент в куче было S камней; 1 ≤ S ≤ 100.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника.

Найдите два наименьших значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

Найденные значения запишите в ответе в порядке возрастания через пробел.

Ответ11 30

Решение

Петя должен первым ходом перевести игру в позицию, из которой Ваня не может выиграть сразу, но после любого хода Вани Петя заканчивает игру. При этом выиграть первым ходом Петя не должен. В программе: f(S, 3) (Петя выигрывает не позже второго хода) и не f(S, 1) (но не первым ходом).

Подходят S = 11, 30, 31. Нужны два наименьших из них.

Проверка для S = 11: выиграть первым ходом Петя не может, а ходом 11 → 33 он ставит Ваню в проигрышную позицию: любой ход Вани (слева) Петя заканчивает выигрышным ходом (справа):

35 → 105
99 → 101

Программа: f(p, m) — может ли «наш» игрок выиграть из позиции p не более чем за m полуходов (на нечётном m ходит «наш» игрок — нужен хотя бы один хороший ход, any; на чётном ходит соперник — хорошими должны быть все его ходы, all).

from functools import lru_cache


def moves(x):
    return [x + 2, x * 3]


def done(x):
    return x >= 101


@lru_cache(None)
def f(p, m):
    if done(p):
        return m % 2 == 0
    if m == 0:
        return False
    h = [f(q, m - 1) for q in moves(p)]
    return any(h) if m % 2 else all(h)


R = range(1, 101)
a20 = [s for s in R if f(s, 3) and not f(s, 1)]
print(a20[0], a20[1])

Ответ: 11 30.

Решить такую задачу — новый вариант с проверкой

Задание 20 ЕГЭ: другие виды

Все задачи задания 20 вперемешку · разбор: как решать задание 20 · пробные варианты ЕГЭ