Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 6 · площадь фигуры

Задание 6 ЕГЭ: площадь фигуры

Черепаха: площадь фигуры. Тема номера — исполнитель черепаха. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n – целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n – целое число), вызывающая передвижение в противоположном голове направлении; Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m – целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм.

Повтори 3 [Вперёд 21 Направо 90 Вперёд 18 Направо 90]
Поднять хвост
Вперёд 24 Направо 90 Назад 17
Опустить хвост
Повтори 7 [Вперёд 55 Налево 90 Назад 21 Налево 90]

Определите площадь пересечения фигур, ограниченных заданными алгоритмом линиями.

Ответ324

Решение

Одна итерация цикла рисует две стороны прямоугольника и поворачивает Черепаху на 180°, поэтому за две итерации прямоугольник замыкается, а остальные повторы обводят ту же линию.

Первая фигура: 0 ≤ x ≤ 18, 0 ≤ y ≤ 21. Повторений 3 — нечётное число, после цикла Черепаха в точке (18; 21), голова направлена вниз.

Переезд без рисования приводит её в точку (35; −3), голова направлена влево. Вторая фигура (повторений 7): −20 ≤ x ≤ 35, −3 ≤ y ≤ 18.

Общая часть: 0 ≤ x ≤ 18, 0 ≤ y ≤ 18, её площадь 18 · 18 = 324.

from math import cos, sin, radians

def run(prog):
    # контуры нарисованных фигур: вершины до первого возвращения в начальную точку
    x = y = 0
    ang = 90                                   # голова вдоль оси ординат
    paths, cur = [], [(0, 0)]
    for cmd, n in prog:
        if cmd in ("fd", "bk"):
            d = n if cmd == "fd" else -n
            x += round(d * cos(radians(ang)))   # повороты кратны 90°: смещения целые
            y += round(d * sin(radians(ang)))
            if cur is not None:
                cur.append((x, y))
        elif cmd == "rt":
            ang -= n
        elif cmd == "lt":
            ang += n
        elif cmd == "up":
            paths.append(cur)
            cur = None
        elif cmd == "down":
            cur = [(x, y)]
    if cur is not None:
        paths.append(cur)
    return [f[:f.index(f[0], 1)] for f in paths]

prog = (3 * [("fd", 21), ("rt", 90), ("fd", 18), ("rt", 90)]
        + [("up", 0)]
        + [("fd", 24), ("rt", 90), ("bk", 17)]
        + [("down", 0)]
        + 7 * [("fd", 55), ("lt", 90), ("bk", 21), ("lt", 90)])

boxes = []
for f in run(prog):
    xs = [q[0] for q in f]
    ys = [q[1] for q in f]
    boxes.append((min(xs), max(xs), min(ys), max(ys)))   # x1, x2, y1, y2
print(boxes)

(ax1, ax2, ay1, ay2), (bx1, bx2, by1, by2) = boxes
w = min(ax2, bx2) - max(ax1, bx1)              # стороны общей части
h = min(ay2, by2) - max(ay1, by1)
common = w * h if w > 0 and h > 0 else 0
print(common)

Решить такую задачу — новый вариант с проверкой

Задание 6 ЕГЭ: другие виды

Все задачи задания 6 вперемешку · разбор: как решать задание 6 · пробные варианты ЕГЭ