Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 8 · числа с условиями на цифры

Задание 8 ЕГЭ: числа с условиями на цифры

Числа в системе счисления: различные цифры и условия на цифры. Тема номера — комбинаторика и перебор слов. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Сколько существует четырёхзначных чисел, записанных в пятеричной системе счисления, все цифры которых различны и никакие две чётные и никакие две нечётные цифры не стоят рядом?

Ответ20

Решение

Чётность цифр должна чередоваться, поэтому есть два шаблона: чётная, нечётная, … или нечётная, чётная, … Чётных цифр в системе 3 (включая 0), нечётных — 2. Для каждого шаблона чётные места заполняем различными чётными цифрами, нечётные — различными нечётными (размещения), а из шаблона с чётной первой цифрой вычитаем варианты с нулём впереди.

Проверка перебором:

from itertools import permutations

cnt = 0
for t in permutations(range(5), 4):
    if t[0] == 0:
        continue
    if all(t[i] % 2 != t[i + 1] % 2 for i in range(3)):
        cnt += 1
print(cnt)

Ответ: 20.

Решить такую задачу — новый вариант с проверкой

Задание 8 ЕГЭ: другие виды

Все задачи задания 8 вперемешку · разбор: как решать задание 8 · пробные варианты ЕГЭ