Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 9 · повторы чисел в строке и суммы

Задание 9 ЕГЭ: повторы чисел в строке и суммы

Электронная таблица: повторы чисел и условие на суммы. Тема номера — обработка данных в электронной таблице. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Задание выполняется с использованием прилагаемого файла.

Откройте файл электронной таблицы 9.xlsx, содержащей в каждой строке 4 натуральных чисел. Определите количество строк таблицы, для которых выполнены оба условия:

В ответе запишите только число.

Скачать файл к примеру

Ответ1655

Решение

Для каждой строки считаем, сколько раз встречается каждое число (Counter). Структурное условие — набор кратностей [1, 1, 1, 1] по убыванию; числовое проверяем прямо по строке. В таблице это делается формулами: СЧЁТЕСЛИ по строке для каждого из столбцов A–D, затем условия через И/ЕСЛИ.

Ответ: 1655.

from collections import Counter
from openpyxl import load_workbook

ws = load_workbook('9.xlsx').active
cnt = 0
for r in ws.iter_rows(values_only=True):
    r = list(r)
    c = Counter(r)
    if sorted(c.values(), reverse=True) == [1, 1, 1, 1] and not (r[0] + r[1] == r[2] + r[3] or r[0] + r[2] == r[1] + r[3] or r[0] + r[3] == r[1] + r[2]):
        cnt += 1
print(cnt)

Решить такую задачу — новый вариант с проверкой

Задание 9 ЕГЭ: другие виды

Все задачи задания 9 вперемешку · разбор: как решать задание 9 · пробные варианты ЕГЭ