Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 15 · делимость ДЕЛ(x, A)

Задание 15 ЕГЭ: делимость ДЕЛ(x, A)

ДЕЛ(x, A): наибольшее или наименьшее A. Тема номера — логические выражения с параметром. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Пусть на числовой прямой дан отрезок B = [136; 165].

Для какого наибольшего натурального числа A формула

¬ДЕЛ(x, A) → (¬(x ∈ B) ∨ ¬ДЕЛ(x, 21))

тождественно истинна (т.е. принимает значение 1 при любом натуральном значении переменной x)?

В ответе запишите число.

Ответ147

Решение

Выражение ложно только тогда, когда x ∈ B, x делится на 21 и при этом x не делится на A. Значит, на A обязаны делиться все числа отрезка [136; 165], кратные 21: 147. Такое число одно, поэтому наибольшее A = 147.

Проверим перебором: A от 1000 вниз, x от 1 до 10 000; первое подходящее A и есть наибольшее.

def ok(A):
    for x in range(1, 10001):
        if not ((not (x % A == 0)) <= ((not (136 <= x <= 165)) or (not (x % 21 == 0)))):
            return False
    return True

for A in range(1000, 0, -1):
    if ok(A):
        print(A)
        break

Ответ: 147.

Решить такую задачу — новый вариант с проверкой

Задание 15 ЕГЭ: другие виды

Все задачи задания 15 вперемешку · разбор: как решать задание 15 · пробные варианты ЕГЭ