Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 15 · отрезки на числовой прямой

Задание 15 ЕГЭ: отрезки на числовой прямой

Отрезки на числовой прямой: длина отрезка A. Тема номера — логические выражения с параметром. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

На числовой прямой даны два отрезка: B = [212; 496] и C = [328; 554]. Укажите наименьшую возможную длину такого отрезка A, для которого логическое выражение

(x ∈ A) ∨ ¬((x ∈ C) ∨ (x ∈ B))

истинно (т.е. принимает значение 1) при любом значении переменной x.

В ответе запишите число.

Ответ342

Решение

Выражение должно принимать значение 1 при любом x. Если x не лежит в A, это нарушается в точках множества [212; 554] — все они обязаны попасть в A. Отрезок A сплошной, поэтому наименьший подходящий A = [212; 554]. Его длина 554 − 212 = 342.

Проверка программой: концы отрезков целые, поэтому достаточно проверить точки с шагом 0,5 (целые точки и середины между ними).

import math

def f(x, A):
    B = 212 <= x <= 496
    C = 328 <= x <= 554
    return (A or (not (C or B)))

xs = [k / 2 for k in range(420, 1113)]  # шаг 0,5
need = [x for x in xs if not f(x, False)]  # без A выражение не выполняется — x обязан лежать в A
# концы данных отрезков целые, поэтому концы A — тоже целые числа
print(math.ceil(max(need)) - math.floor(min(need)))

Ответ: 342.

Решить такую задачу — новый вариант с проверкой

Задание 15 ЕГЭ: другие виды

Все задачи задания 15 вперемешку · разбор: как решать задание 15 · пробные варианты ЕГЭ