Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 15 · неравенства с двумя переменными

Задание 15 ЕГЭ: неравенства с двумя переменными

Неравенства с x и y: наименьшее или наибольшее A. Тема номера — логические выражения с параметром. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Для какого наибольшего целого числа A выражение

(6x + 5y ≥ A) ∨ (x < 3) ∨ (y < 21)

тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y?

Ответ123

Решение

Выражение ложно, только если ложны все скобки. Остальные скобки ложны в области x ≥ 3 и y ≥ 21. Там должно выполняться 6x + 5y ≥ A. Значение 6x + 5y растёт с ростом x и y, поэтому его наименьшее значение в области — в точке x = 3, y = 21: 123. Значит, A не больше 123: наибольшее A = 123.

Проверка перебором: x и y берём до 400 — это заведомо больше границ области.

def f(x, y, A):
    return (6 * x + 5 * y >= A) or (x < 3) or (y < 21)

for A in range(1123, -1, -1):
    if all(f(x, y, A) for x in range(400) for y in range(400)):
        print(A)
        break

Ответ: 123.

Решить такую задачу — новый вариант с проверкой

Задание 15 ЕГЭ: другие виды

Все задачи задания 15 вперемешку · разбор: как решать задание 15 · пробные варианты ЕГЭ