Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 17 · элементы последовательности

Задание 17 ЕГЭ: элементы последовательности

Элементы последовательности с условием. Тема номера — обработка последовательности из файла. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Задание выполняется с использованием прилагаемого файла.

В файле 17.txt содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от −10 000 до 10 000 включительно. Рассматриваются элементы последовательности, которые меньше среднего арифметического всех чисел последовательности и не делятся на 7. Найдите количество таких чисел и максимальное из них.

В ответе запишите сначала количество, затем максимальное число.

Запишите два числа через пробел.

Скачать файл к примеру

Ответ993 1

Решение

Переводим каждое условие в выражение Python и проходим по всем числам, считая подходящие (счётчик и текущий максимум). Среднее арифметическое относится ко всей последовательности, поэтому сначала считаем его по всему файлу, а потом проверяем элементы. «Не делится» — остаток от деления не равен нулю.

Ответ: 993 1.

a = [int(s) for s in open("17.txt")]
avg = sum(a) / len(a)   # среднее по всему файлу — считаем заранее

count = 0
mx = -10 ** 9
for x in a:
    if x < avg and x % 7 != 0:
        count += 1
        mx = max(mx, x)
print(count, mx)

Решить такую задачу — новый вариант с проверкой

Задание 17 ЕГЭ: другие виды

Все задачи задания 17 вперемешку · разбор: как решать задание 17 · пробные варианты ЕГЭ