Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 17 · пары соседних элементов

Задание 17 ЕГЭ: пары соседних элементов

Пары соседних элементов. Тема номера — обработка последовательности из файла. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Задание выполняется с использованием прилагаемого файла.

В файле 17.txt содержится последовательность натуральных чисел. Элементы последовательности могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар последовательности, в которых хотя бы один из элементов больше среднего арифметического всех чисел файла, а сумма элементов пары кратна 34. В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Запишите два числа через пробел.

Скачать файл к примеру

Ответ73 180880

Решение

Среднее арифметическое считаем по всему файлу заранее, затем проходим по соседним парам.

Ответ: 73 180880.

a = [int(s) for s in open("17.txt")]
avg = sum(a) / len(a)

count = 0
best = -10 ** 9
for x, y in zip(a, a[1:]):
    if (x > avg or y > avg) and (x + y) % 34 == 0:
        count += 1
        best = max(best, x + y)
print(count, best)

Решить такую задачу — новый вариант с проверкой

Задание 17 ЕГЭ: другие виды

Все задачи задания 17 вперемешку · разбор: как решать задание 17 · пробные варианты ЕГЭ