Информатика: ОГЭ и ЕГЭ

Разборы · ЕГЭ, задание 17

Задание 17 ЕГЭ по информатике: обработка последовательности из файла

Что проверяет задание

К заданию приложен текстовый файл с последовательностью целых чисел. Нужно найти пары (или тройки) подряд идущих элементов с заданным свойством и записать два числа: количество таких пар и, например, максимальную сумму в них. 1 балл — только если оба числа верны.

Что нужно знать

Как решать

  1. Прочитайте файл и посчитайте нужные характеристики всей последовательности.
  2. Пройдите по парам, проверьте условие, копите количество и максимум (минимум).
  3. Запишите два числа через пробел в том порядке, который указан в условии.

Пример из демоверсии 2027

В файле последовательность натуральных чисел от 1 до 100 000. Определите количество пар, в которых остаток от деления на 33 хотя бы одного элемента равен минимальному элементу последовательности, и максимальную сумму элементов таких пар. Пара — два идущих подряд элемента.

a = [int(s) for s in open("17.txt")]
mn = min(a)
count, best = 0, 0
for x, y in zip(a, a[1:]):
    if x % 33 == mn or y % 33 == mn:
        count += 1
        best = max(best, x + y)
print(count, best)

Для файла демоверсии программа выводит 622 174933.

Типичные ошибки

Потренироваться: задание 17 новые варианты с проверкой ответа

Подготовиться с репетитором

На занятиях разбираем каждое задание в формате экзамена и отрабатываем его на тренажёрах с проверкой по критериям.

Записаться на пробное занятие

Другие разборы