Информатика: ОГЭ и ЕГЭ

Разборы · ЕГЭ, задание 14

Задание 14 ЕГЭ по информатике: системы счисления

Что проверяет задание

В задании 14 нужно работать с числами в разных системах счисления: найти неизвестную цифру в записи операндов, посчитать нули или другие цифры в записи большого выражения. 1 балл. Числа здесь огромные, поэтому задание решают программой — в Python целые числа не переполняются.

Что нужно знать

Как решать

  1. Напишите функцию перевода, в которой цифра x подставляется как число.
  2. Переберите x по всем цифрам системы.
  3. Проверьте условие и выведите то, что спрашивают (не всегда сам x!).

Пример из демоверсии 2027

Операнды записаны в системе с основанием 22: 27x98876₂₂ + 26x51₂₂ + 711x5₂₂. Найдите наименьшее x, при котором значение выражения кратно 21, и запишите частное от деления значения на 21 в десятичной системе.

def value(s, x, base=22):
    v = 0
    for ch in s:
        d = x if ch == "x" else int(ch)
        v = v * base + d
    return v

for x in range(22):
    total = value("27x98876", x) + value("26x51", x) + value("711x5", x)
    if total % 21 == 0:
        print(x, total // 21)
        break

Программа выводит найденное x и частное. В ответ идёт частное: 276296118.

В других вариантах просят посчитать цифры в записи выражения вида 3 · 31258 + … в системе с основанием 25 — тогда вычисляем значение и делим его на основание в цикле, считая нужные остатки.

Типичные ошибки

Потренироваться: задание 14 новые варианты с проверкой ответа

Подготовиться с репетитором

На занятиях разбираем каждое задание в формате экзамена и отрабатываем его на тренажёрах с проверкой по критериям.

Записаться на пробное занятие

Другие разборы