Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 24 · корректная запись числа или выражения

Задание 24 ЕГЭ: корректная запись числа или выражения

Корректная запись числа или выражения. Тема номера — обработка символьных строк. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Задание выполняется с использованием прилагаемого файла.

Текстовый файл 24.txt содержит строку из 20 000 символов — десятичных цифр и знаков + и -.

Определите максимальную длину непрерывной цепочки цифр, которая является корректной записью натурального числа или нуля, то есть не содержит незначащих (ведущих) нулей.

Например, 7182 и 0 — корректные записи, а 0678 и 00 — нет.

Для выполнения этого задания следует написать программу.

Скачать файл к примеру

Ответ44

Решение

В каждом максимальном блоке цифр лучшая корректная запись — весь блок без ведущих нулей (или один ноль, если блок состоит только из нулей).

Ответ: 44.

import re

s = open("24.txt").read().strip()
best = 0
for block in re.findall(r"[0-9]+", s):     # максимальные блоки цифр
    number = block.lstrip("0") or "0"       # без ведущих нулей
    best = max(best, len(number))
print(best)

Решить такую задачу — новый вариант с проверкой

Задание 24 ЕГЭ: другие виды

Все задачи задания 24 вперемешку · разбор: как решать задание 24 · пробные варианты ЕГЭ