Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 24 · подсчёт вхождений сочетаний

Задание 24 ЕГЭ: подсчёт вхождений сочетаний

Подсчёт вхождений сочетаний. Тема номера — обработка символьных строк. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Задание выполняется с использованием прилагаемого файла.

Текстовый файл 24.txt содержит строку из 100 000 символов — заглавных латинских букв A, B, C, D и E.

Определите, сколько в строке пар соседних одинаковых символов. Учитываются все такие пары: например, в строке AAAC их две.

Для выполнения этого задания следует написать программу.

Скачать файл к примеру

Ответ19981

Решение

Сравниваем каждый символ со следующим.

Ответ: 19981.

s = open("24.txt").read().strip()
count = 0
for i in range(len(s) - 1):
    if s[i] == s[i + 1]:
        count += 1
print(count)

Решить такую задачу — новый вариант с проверкой

Задание 24 ЕГЭ: другие виды

Все задачи задания 24 вперемешку · разбор: как решать задание 24 · пробные варианты ЕГЭ