Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 24 · самая длинная цепочка без запрещённых символов

Задание 24 ЕГЭ: самая длинная цепочка без запрещённых символов

Самая длинная цепочка символов. Тема номера — обработка символьных строк. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Задание выполняется с использованием прилагаемого файла.

Текстовый файл 24.txt содержит строку из 10 000 символов — заглавных латинских букв A, B, C и D.

Определите максимальное количество идущих подряд символов, среди которых нет пары символов BD (буква B, сразу за ней буква D).

Для выполнения этого задания следует написать программу.

Скачать файл к примеру

Ответ142

Решение

Цепочка не может содержать одновременно B и следующую за ней D, поэтому каждое вхождение BD «разрезает» строку между этими буквами. Считаем длину текущей цепочки; встретив D сразу после B, начинаем новую цепочку с этой буквы D (длина 1).

Ответ: 142.

s = open("24.txt").read().strip()
best = cur = 1
for i in range(1, len(s)):
    if s[i - 1] == "B" and s[i] == "D":
        cur = 1          # новая цепочка начинается с этой буквы
    else:
        cur += 1
    best = max(best, cur)
print(best)

Решить такую задачу — новый вариант с проверкой

Задание 24 ЕГЭ: другие виды

Все задачи задания 24 вперемешку · разбор: как решать задание 24 · пробные варианты ЕГЭ