Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 24 · запись числа в системе счисления

Задание 24 ЕГЭ: запись числа в системе счисления

Запись числа в системе счисления с основанием 11–16. Тема номера — обработка символьных строк. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Задание выполняется с использованием прилагаемого файла.

Текстовый файл 24.txt содержит строку из заглавных латинских букв и десятичных цифр, всего не более 50 000 символов.

Определите в прилагаемом файле максимальное количество идущих подряд символов, которые образуют запись натурального числа в системе счисления с основанием 11. Запись числа не должна начинаться с нуля; цифры больше девяти обозначаются заглавными латинскими буквами A, B, C, … (как в шестнадцатеричной системе).

Для выполнения этого задания следует написать программу.

Скачать файл к примеру

Ответ108

Решение

Строку делят на блоки из допустимых цифр системы. В каждом блоке самая длинная запись начинается с первой ненулевой цифры и идёт до конца блока.

Ответ: 108.

s = open('24.txt').read().strip()
ok = set('0123456789A')
best = cur = 0          # cur — длина записи без ведущих нулей, которая заканчивается здесь
for c in s:
    if c not in ok:
        cur = 0
    elif cur == 0 and c == '0':
        continue
    else:
        cur += 1
        best = max(best, cur)
print(best)

Решить такую задачу — новый вариант с проверкой

Задание 24 ЕГЭ: другие виды

Все задачи задания 24 вперемешку · разбор: как решать задание 24 · пробные варианты ЕГЭ