Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 14 · число нулей в записи

Задание 14 ЕГЭ: число нулей в записи

Наибольшее или наименьшее число нулей в записи. Тема номера — системы счисления. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Значение арифметического выражения 4·989 + 8·957 − x, где x — целое число от 1 до 500 включительно, записали в системе счисления с основанием 9.

Определите наибольшее возможное количество нулей в этой записи. В ответе запишите это количество.

Ответ33

Решение

Перебираем все x от 1 до 500: для каждого переводим значение в систему с основанием 9 делением и считаем нули. Ответ — наибольшее из полученных количеств.

Ответ: 33.

def zeros(v, q):
    z = 0
    while v:
        v, r = divmod(v, q)
        z += r == 0
    return z

print(max(zeros(4 * 9 ** 89 + 8 * 9 ** 57 - x, 9) for x in range(1, 501)))

Решить такую задачу — новый вариант с проверкой

Задание 14 ЕГЭ: другие виды

Все задачи задания 14 вперемешку · разбор: как решать задание 14 · пробные варианты ЕГЭ