Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 14 · неизвестная цифра x и кратность

Задание 14 ЕГЭ: неизвестная цифра x и кратность

Неизвестная цифра x: кратность суммы или разности. Тема номера — системы счисления. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Операнды арифметического выражения записаны в системе счисления с основанием 23.

206x623 + 9627x23 + 526x23

В записи чисел переменной x обозначена неизвестная цифра из алфавита 23-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 22. Для найденного x вычислите частное от деления значения арифметического выражения на 22 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

Ответ146264

Решение

Перебираем цифру x от 0 до 22 (все цифры 23-ричной системы) по убыванию, переводим операнды в десятичную систему по схеме Горнера и проверяем делимость значения выражения на 22. Цифра x может быть больше 9, поэтому число собираем по цифрам, а не через int(строка, 23).

def value(s, x, base=23):
    v = 0
    for ch in s:
        d = x if ch == "x" else int(ch)
        v = v * base + d
    return v

for x in range(22, -1, -1):
    total = value("206x6", x) + value("9627x", x) + value("526x", x)
    if total % 22 == 0:
        print(total // 22)
        break

Подходящие значения x: 5; наибольшее — x = 5. Значение выражения 3217808, частное 3217808 / 22 = 146264.

Ответ: 146264.

Решить такую задачу — новый вариант с проверкой

Задание 14 ЕГЭ: другие виды

Все задачи задания 14 вперемешку · разбор: как решать задание 14 · пробные варианты ЕГЭ