Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 14 · цифры в записи значения выражения

Задание 14 ЕГЭ: цифры в записи значения выражения

Цифры в записи значения выражения из степеней. Тема номера — системы счисления. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Значение арифметического выражения

5 · 910 + 5 · 311 + 6 · 59049 + 1384

записали в системе счисления с основанием 3. Определите сумму числовых значений цифр этой записи. Ответ запишите в десятичной системе счисления.

Ответ14

Решение

Python работает с длинными целыми числами, поэтому значение выражения можно вычислить точно и перевести в систему с основанием 3 делением с остатком: остатки от деления на 3 — это цифры записи справа налево (ведущих нулей при таком переводе не бывает). Все основания степеней — степени числа 3 (59049 = 310, 9 = 32): запись устроена просто, но цифр в ней много — надёжнее посчитать программой.

v = 5 * 9**10 + 5 * 3**11 + 6 * 59049 + 1384
count = 0
while v > 0:
    count += v % 3
    v //= 3
print(count)

Ответ: 14.

Решить такую задачу — новый вариант с проверкой

Задание 14 ЕГЭ: другие виды

Все задачи задания 14 вперемешку · разбор: как решать задание 14 · пробные варианты ЕГЭ