Информатика: ОГЭ и ЕГЭ

Тренировка ЕГЭ · задание 14 · подбор x по числу нулей

Задание 14 ЕГЭ: подбор x по числу нулей

Подбор x по числу нулей в записи значения выражения. Тема номера — системы счисления. Ниже — пример с ответом и решением; кнопкой под ним можно решить такую же задачу с другими числами, ответ проверится сразу.

Пример

Значение арифметического выражения 9231 + 3 · 9184 − x, где x — натуральное число, не превышающее 2500, записали в 9-ричной системе счисления.

Определите наименьшее количество нулей, которое может содержаться в этой записи.

Ответ46

Решение

Все слагаемые без x делятся на 94 = 6561 > 2500, поэтому V − x = (V / 94 − 1) · 94 + (6561 − x). Старшая часть от x не зависит и содержит 46 нулей, а младшие 4 цифры — запись числа 6561 − x (с ведущими нулями). Так задачу можно решить и вручную, но проще перебрать все x программой.

Перебираем x от 1 до 2500, переводим значение в систему с основанием 9 делением с остатком и считаем нули.

def zeros(v):
    cnt = 0
    while v > 0:
        cnt += v % 9 == 0
        v //= 9
    return cnt

V = 9**231 + 3 * 9**184
counts = {x: zeros(V - x) for x in range(1, 2501)}
print(min(counts.values()))

Ответ: 46.

Решить такую задачу — новый вариант с проверкой

Задание 14 ЕГЭ: другие виды

Все задачи задания 14 вперемешку · разбор: как решать задание 14 · пробные варианты ЕГЭ